Switch and Router Basic Configuration LAB
In this lab you will complete a basic configuration on a switch, verify Cisco Discovery Protocol and the effects of Interface speed and duplex configuration.
Download: Packet Tracer Setup file
Cisco Router and Switch Initial Configuration
1. Configure Router 1 with the hostname R1
2. Configure Router 2 with the hostname R2
3. Configure Switch 1 with the hostname SW1
4. Configure the IP address on R1 according to the topology diagram
5. Configure the IP address on R2 according to the topology diagram
6. Give SW1 the management IP address 10.10.10.10
7. The Switch should only have connectivity to other subnets via R2
8. Verify the switch can ping its default gateway
9. Enter suitable descriptions on the interfaces connecting to the devices
10. On SW1, verify that speed and Duplex are automatically negotiated to 100 mbps full on the the link to R1
11. Manually Configure full Dupley and FastEthernet on the link to R2
12. What version of IOS is the switch running?
Cisco Discovery Protocol (CDP) Configuration
13. Verify the directly attached Cisco neighbours using the Cisco Discovery Protocol.
14. Prevent R1 from discovering information about Switch 1 via CDP
15. Flush the CDP cache on R1 by enetering no cdp run then cdp run commands in global configuration mode
16. Verify that R1 cannot see SW1 via CDP
17. Verify the status of the switchport connected to R2 with the show ip interface brief command, it should show the status up/up.
18. Shutdown the interface connected to R2 and issue a show ip interface brief command again.
19. Bring the interface up again. Verify the speed of the duplex setting.
20. Set the duplex to half on Switch 1. Leave the settings as they are on R2.
21. Verify the state of the interface.
22. Set the Duplex back to full duplex.
23. Set the speed to 10Mbps
24. Check if the interface is still operational
25. Check if the interface is still operational on R2, what is the status of the interface?
Cisco Router and Switch Initial Configuration
1. Configure Router 1 with the hostname R1
router>enable
router#conf
router#configure term
router#configure terminal
router(config)#hostname R1
R1(config)#exit
R2#copy run start
2. Configure Router 2 with the hostname R2
router>enable
router#conf
router#configure term
router#configure terminal
router(config)#hostname R2
R2(config)#exit
R2#copy run start
3. Configure Switch 1 with the hostname SW1
switch>enable
switch#conf
switch#configure term
switch#configure terminal
switch(config)#hostname sw1
sw1(config)#exit
R2#copy run start
4. Configure the IP address on R1 according to the topology diagram
R1 (config-if)#interface FastEthernet0/0
R1 (config-if)#ip address 10.10.10.1 255.255.255.0
R1 (config-if)#no shutdown
5. Configure the IP address on R2 according to the topology diagram
R2 (config-if)#interface FastEthernet0/0
R2 (config-if)#ip address 10.10.10.2 255.255.255.0
R2 (config-if)#no shutdown
6. Give SW1 the management IP address 10.10.10.10
sw1(config)#interface vlan1
sw1(config-if)#ip add
sw1(config-if)#ip address 10.10.10.10 255.255.255.0
sw1(config-if)#no shutdown
7. The Switch should have connectivity to other subnets via R2
sw1(config)#ip default-gateway 10.10.10.2
8. Verify the switch can ping its default gateway
sw1>ping 10.10.10.2
Sending 5, 100-byte ICMP Echos to 10.10.10.2, timeout is 2 seconds:.!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 0/0/0 ms
9. Enter suitable descriptions on the interfaces connecting to the devices
r1(config)#int fa0/0
r1(config-if)#description
r1(config-if)#description link to sw1 0/2
r2(config)#int fa0/0
r2(config-if)#description
r2(config-if)#description link to sw1 0/2
sw1(config)#interface fa0/1
sw1(config-if)#description link to r1
sw1(config)#interface fa0/2
sw1(config-if)#description link to r2
10. On SW1, verify that speed and Duplex are automatically negotiated to 100 mbps full on the the link to R1
sw1#show interfaces fa0/1
FastEthernet 0/1 is up, line protocol is up (connected)
Hardware is Lance, address is 00e0.8fd6.8901 (bia 00e0.8fd6.8901)
BW 100000 Kbit, DLY 1000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec) Full-duplex, 100Mb/s
11. Manually Configure full Duplex and FastEthernet on the link to R2
sw1(config)#interface fa0/2
sw1(config-if)#speed 100
sw1(config-if)#duplex full
sw1(config-if)#
%LINK-3-UPDOWN: Interface FastEthernet0/2, changed state to down
notice the state is down ! so its lost connectivity to the R2 fa0/0
r2(config)#interface fa0/0
r2(config-if)#speed 100
r2(config-if)#duplex full
12. What version of IOS is the switch running?
sw1>show version
Cisco IOS Software, C2960 Software (C2960-LANBASE-M), Version 12.2(25)FX, RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2005 by Cisco Systems, Inc.
Compiled Wed 12-Oct-05 22:05 by pt_team
ROM: C2960 Boot Loader (C2960-HBOOT-M) Version 12.2(25r)FX, RELEASE SOFTWARE (fc4)
Cisco Discovery Protocol (CDP) configuration
13. Verify the directly attached Cisco neighbours using the Cisco Discovery Protocol.
sw1#show cdp neighbors
Capability Codes: R – Router, T – Trans Bridge, B – Source Route Bridge
S – Switch, H – Host, I – IGMP, r – Repeater, P – Phone
Device ID Local Intrfce Holdtme Capability Platform Port ID
r2 Fas 0/2 129 R C2800 Fas 0/0
r1 Fas 0/1 129 R C2800 Fas 0/0
14. Prevent R1 from discovering information about
Switch 1 via CDP
sw1(config)#interface fa0/1
sw1(config-if)#no cdp enable
15. Flush the CDP cache on R1 by enetering no cdp run then cdp run commands in global configuration mode.
r1(config)#no cdp run
r1(config)#cdp run
16. Verify that R1 cannot see SW1 via CDP
r1#show cdp neighbors
Capability Codes: R – Router, T – Trans Bridge, B – Source Route Bridge
S – Switch, H – Host, I – IGMP, r – Repeater, P – Phone
Device ID Local Intrfce Holdtme Capability Platform Port ID
sw1 Fas 0/0 135 S 2960 Fas 0/1
17. Verify the status of the switchport connected to R2 with the show ip interface brief command, it should show the status up/up.
sw1#show ip interface brief
Interface IP-Address OK? Method Status Protocol FastEthernet0/1 unassigned YES manual up up
FastEthernet0/2 unassigned YES manual up up
Vlan1 10.10.10.10 YES manual up up
18. Shutdown the interface connected to R2 and issue a show ip interface brief command again.
Interface IP-Address OK? Method Status Protocol
FastEthernet0/1 unassigned YES manual up up
FastEthernet0/2 unassigned YES manual administratively down down
19. Bring the interface up again. Verify the speed of the duplex setting.
sw1(config)#interface fa0/2
sw1(config-if)#no shutdown
sw1(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/2, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to up
sw1(config)#do sh int fa0/2
FastEthernet0/2 is up, line protocol is up (connected)
Hardware is Lance, address is 00e0.8fd6.8902 (bia 00e0.8fd6.8902)
Description: link to r2
BW 100000 Kbit, DLY 1000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 100Mb/s
20. Set the duplex to half on Switch 1. Leave the settings as they are on R2.
sw1(config-if)#duplex half
sw1(config-if)#
%LINK-3-UPDOWN: Interface FastEthernet0/2, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to down
21. Verify the state of the interface.
r2(config-if)#do show ip interface bri
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 10.10.10.2 YES manual up down
FastEthernet0/1 unassigned YES unset administratively down down
Vlan1 unassigned YES unset administratively down down
22. Set the Duplex back to full duplex.
sw1(config)#interface fa0/2
sw1(config-if)#duplex full
23. Set the speed to 10Mbps
sw1(config-if)#duplex full
sw1(config-if)#speed 10
24. Check if the interface is still operational
sw1(config)#do show ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/1 unassigned YES manual up up
FastEthernet0/2 unassigned YES manual down down
25. Check if the interface is still operational on R2, what is the status of the interface?
r2#show ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 10.10.10.2 YES manual up down
FastEthernet0/1 unassigned YES unset administratively down down
Vlan1 unassigned YES unset administratively down down